Resultados 1 al 6 de 6


ApkManager para Roms 4.3.


Estás en el tema ApkManager para Roms 4.3. dentro del subforo ROMs y desarrollo Samsung Galaxy S III en Esp-Desarrolladores. Bueno, he recibido varias preguntas relacionadas con lo mismo los últimos días, sobre qué herramienta uso yo para modificar las apks y demás. En este enlace os dejo el Apkmanager, modificado en su día por Wanam para añadirle una opción y que yo he ido actualizando últimamente. Descargar de Aquí En la carpeta other ya tenéis: - un framework-res.apk y un twframework-res.apk de base 4.3 de samsung que deberéis cargar antes de usar el apkmanager cuando modifiquéis apks de samsung o...



Este tema tuvo 2810 Visitas y 5 Respuestas

Actualmente hay 1 usuarios viendo este tema. (0 miembros y 1 visitantes)

  1. #1
    Fecha de ingreso
     Mar-2013
    Mensajes
     12,594
    Gracias Enviadas
    8,662
    Agradecido 22,992 Veces en 7,864 Posts


    Bueno, he recibido varias preguntas relacionadas con lo mismo los últimos días, sobre qué herramienta uso yo para modificar las apks y demás.

    En este enlace os dejo el Apkmanager, modificado en su día por Wanam para añadirle una opción y que yo he ido actualizando últimamente.

    Descargar de Aquí


    En la carpeta other ya tenéis:

    - un framework-res.apk y un twframework-res.apk de base 4.3 de samsung que deberéis cargar antes de usar el apkmanager cuando modifiquéis apks de samsung o apks que no requieran api mayor a 18.

    - Un framework 4.4.2 para cuando necesitéis trastear aplicaciones que requieran api 19. Por ejemplo, si queréis hacer modificaciones en ciertas apks de google váis a necesitar cargar este framework si no queréis tener errores en la compilación. Se llama 442framework-res.apk


    Es para windows.


    Recordad que los pasos correctos son:

    1.- Abrir ventana de comandos y situarnos en la carpeta other
    2.- Cargar frameworks:

    En general

    apktool.bat if framework-res.apk

    y después

    apktool.bat if twframework-res.apk


    Y en el caso de apks api 19 (os daréis cuenta enseguida porque os dará error al compilar aún cuando no hayáis hecho ninguna modificación), como os he dicho, sólo necesitaréis cargar

    apktool.bat if 442framework-res.apk


    Después ponéis cd .. (para ir al raiz de la herramienta), escribimos scritp y ya estamos. Siempre mirad el log.txt que está en la raiz para ver los errores de compilación.

    - Para actualizar el apktool.

    Si samsung saca la versión 4.4 para nuestros S3, pues nada, pilláis un framework-res y un twframework-res.apk y de esas bases y las ponéis en la carpeta other. Si google saca android 4.5, por ejemplo, pues conseguís una rom y metéis el framework-res.apk de esa base en la carpeta other. Para no machacar el framework-res.apk de samsung yo hago lo que habéis visto, pongo el número de versión de android antes del nombre.


    La otra cosa que debéis actualizar es el núcleo de la herramienta, apktool.jar que tenéis en la carpeta other.

    El oficial lo tenéis desde esta página

    https://code.google.com/p/android-ap...downloads/list


    Lo que os he subido tiene el último oficial ( apktool1.5.2.tar.bz2 ), hace tiempo que no se actualiza. Si hubiera actualización, lo bajáis, lo sacáis del bz con jzip o similar y si el archivo .jar viene con otro nombre distinto a apktool.jar lo renombráis y lo ponéis en carpeta other.

    Debéis tener java instalado en la máquina y aseguraros que está en el path (buscad por google y el que no sepa hacerlo lo encuentra rápido)

    No penséis que por poder decompilar una apk con api19 y compilarla os va funcionar. Por ejemplo con las apks de google, con algunas, podemos decompilarla y compilarla con el framework de la 442 y si funcionará, pero no se usarán las funcionalidades o cosas propias del api19 en nuestros s3 con roms basadas en stock de samsung. Funcionan porque por código comprueban el nivel api de nuestra rom y actuan en consecuencia, pero otras apks aunque las podáis compilar no correrán.

    Última edición por Grouxho; 15-02-14 a las 14:30


  2. Los siguientes 15 Usuarios dieron las gracias a Grouxho Por su Mensaje :

    chipo (15-02-14),fancier (15-02-14),gsotom (15-02-14),javato40 (16-02-14),javilonas (15-02-14),jose24sanchez (15-02-14),juymelc (16-02-14),Los Fumetas (17-02-14),makova (15-02-14),melladin (15-02-14),mrbojangle69 (15-02-14),namber07 (15-02-14),neovendtta (15-02-14),trillo (15-02-14),ysaad77 (15-02-14)




  3. #2
    Fecha de ingreso
     Feb-2014
    Ubicación
     BCN
    Mensajes
     1,441
    Versión de ROM
     Stock personalizada
    Versión de Kernel
     Depende
    Modelo de smartphone
     Galaxy SIII
    Tu operador
     vodafone
    Gracias Enviadas
    3,689
    Agradecido 2,602 Veces en 873 Posts


    Gracias como siempre aportando grandes cosas.
    Leer aporta sabiduría..prueba no hace daño.

  4. Los siguientes usuarios agradecieron a neovendtta por su mensaje :

    Grouxho (15-02-14)

  5. #3
    Fecha de ingreso
     May-2013
    Ubicación
     Colombia
    Mensajes
     910
    Versión de ROM
     Green_Goblin 0.5
    Modelo de smartphone
     Galaxy S3
    Tu operador
     Claro
    Gracias Enviadas
    1,297
    Agradecido 412 Veces en 265 Posts


    Tito Grouxho buen aporte..

    Esp-desarrolladores necesita de tu ayuda, cualquier donación voluntaria siempre sera bien recibida. Recuerden, esto es una forma de agradecer a los desarrolladores que trabajan día y noche para ustedes (los usuarios) a que sigan trabajando de manera gratuita y altruista. Todas las donaciones deben hacerse acá:

    Se les agradecerá de todo corazón su aporte.

  6. Los siguientes usuarios agradecieron a ysaad77 por su mensaje :

    Grouxho (15-02-14)

  7. #4
    Fecha de ingreso
     Nov-2013
    Ubicación
     Granada
    Mensajes
     2,946
    Versión de Kernel
     Esperando uno de javilonas, siempre.
    Modelo de smartphone
     One Plus One
    Tu operador
     Vodafone
    Gracias Enviadas
    3,618
    Agradecido 1,528 Veces en 907 Posts


    Muchas gracias Grouxho. Aunque sigo empeñado en hacer trabajar el apktool que descargue para Linux. Me niego a trabajar con win2 y pasar por el tubo
    Ahora iba a probar con este:

    http://forum.xda-developers.com/showthread.php?t=695701

  8. Los siguientes usuarios agradecieron a makova por su mensaje :

    Grouxho (15-02-14)

  9. #5
    Fecha de ingreso
     Dec-2013
    Mensajes
     5
    Gracias Enviadas
    0
    Agradecido 3 Vez en 1 Post


    Una pregunta ... Si yo quiero poner una aplicacion de 4.1.2 en 4.3 .. el framework-res que debo poner en other es el de 4.3 ?? o el de 4.1.2 ???

  10. #6
    Fecha de ingreso
     Mar-2013
    Mensajes
     12,594
    Gracias Enviadas
    8,662
    Agradecido 22,992 Veces en 7,864 Posts


    No creo q puedas. Intenta compilarla con el fr y twfr de la 4.3 a ver si te compila, pero no creo q se te instale. Si es una apk que usa alguna librería de samsung...



Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •  


ESP-Desarrolladores

    ESP-Desarrolladores, es una comunidad de desarrollo Android en habla hispana, Aquí encontrarás lo último en Android, ROMs, Kernel, APPs, etc... Pasa y Ponte Cómodo!!! estás en tu casa ;)

Síguenos en

Twitter Facebook Google+ espdesarrolladores - Andyou Youtube RSS Feed